Question to have a permission to modify pre-configured conda


I am using the workspace created by the AnVIL AC3 program who set up the billing account associated. Under this workspace, I am owner. Since this workspace is not created by myself, the cloud environment (i.e. VM instance) is only allowed to be accessible as a user, currently, jupyter. When I tried to install a python package with conda that is already present, the permission error occurs. I have two questions.

  1. any way to work with conda as a user level (more like conda question)
  2. how to get the password to access the system level, for example, as a jupyter if it is su, or any other root level.


From Terra Support 8:47am EDT

Your request (282116) has been received and is being reviewed by our support staff.

Hi JK,

Thank you for writing in! I’m not sure I fully understand the issue you’re experiencing or your questions. Could you please share the full error that you’re receiving when you tried to install the python package? You should be able to create this custom conda environment at runtime creation with a custom docker image or a startup script to install what you need. The following articles may be useful for you:

Please let me know if this helps address your question.

Kind regards,