AnVIL

Issues cloning a workspace

I tried to clone the AnVIL_GTEx_V8_hg38 workspace by using the Clone option in the teardrop menu. This failed with the error message: Failed to retrieve bucket fc-secure-ff8156a3-ddf3-42e4-9211-0fd89da62108

After this, I tried an alternative method to clone the workspace by downloading and reuploading a tsv of the participant data. Downloading the AnVIL_GTEx_V8_hg38 participant data with the “Download all Rows” Feature in the Data tab of the workspace worked. I then created a new workspace which included Authorization domain Inherited groups AUTH_ANVIL_AnVIL_GTEx_V8_hg38 upon creation. This also worked. However, after trying to re-upload the tsv in the new workspace, I got an error message that it was an Invalid TSV. First column header should start with “workspace”.

Notes: I’m a reader of the AnVIL_GTEx_V8_hg38 workspace. Also, when opening the workspace an error message appears in the top right corner: error message “Error loading bucket location data”, “code : 400”, “message: Bucket is requester pays bucket but no user project provided.”, “domain: global”, “reason: required”

How can I successfully clone the workspace data?

From Terra Support 8:47pm EST

Your request (113855) has been received and is being reviewed by our support staff.

1 Like

From Terra Support 9:40am EST

Thanks for reaching out. When uploading the participant and sample tables to your new workspace, the first column headers for each file should be ‘entity:participant_id’ and ‘entity:sample_id’, respectively. Those two files will be uploaded using the ‘+’ button next to ‘TABLES’:

The Workspace Data TSV file will have ‘workspace:sample_attributes’ as the first column header. This file is uploaded by clicking ‘upload TSV’ in the Workspace Data tab.

I was able to successfully download and upload the files to a new workspace. If you have any trouble uploading the files again, I can share my workspace with you to clone instead.

Thank you! Using the + button next to TABLES worked perfectly! I mistakenly was using the Drag or click to upload TSV in the Workspace Data tab that you referenced on the participant and sample .tsv tables.

1 Like

To summarize, these are the working steps I used to clone a Workspace’s data since the Clone option in the teardrop menu currently wasn’t/isn’t working

I. Download .tsv data from Workspace of interest

  1. Navigate to workspace of interest
  2. Navigate to DATA tab (purple arrow)
  3. Navgiate to TABLES and either participant or sample (blue arrow)
  4. Download .tsv by clicking the DOWNLOAD ALL ROWS button (orange arrow)

II. Create new Workspace and upload the .tsv

  1. Navigate to Workspaces from the hamburger menu button
  2. Create new Workspace by clicking + button next to WORKSPACES. I made sure to match the Authorization domain of the new Workspace to the Workspace of interest that I wanted to clone.
  3. Navigate to the DATA tab of the new Workspace
  4. Click the + button next to TABLES and upload previously downloaded .tsv
  5. The data table should be there!

III. Alternatively, downloading the other workspace data

  1. Follow steps I.1 - I.2 above
  2. Navigate to the OTHER DATA and Workspace Data tabs (blue arrow, below)
  3. Download .tsv by clicking Download TSV link (purple arrow)
  4. If you haven’t created the new workspace you wanted, do so by following the II.1-II.2 steps above or Navigate to the new Worskspace that you already created.
  5. Again, navigate to the OTHER DATA and Workspace Data tabs (blue arrow, below)
  6. Upload your previously downloaded .tsv by clicking upload TSV (red arrow) (Note, your Workspace’s OTHER DATA Workspace Data is unlikely to have any files in it unlike this screenshot)
1 Like